PhishER - Room Notifications Issue (US Only)
Incident Report for KnowBe4
Postmortem

On Tuesday, 11/08/2022, from approximately 5:52 p.m. (ET) until Friday, 11/11/22, at approximately 11:07 a.m. (ET), some users were not receiving PhishER room notifications.

This incident was caused by our monitoring service, which limited the number of notifications that could be sent after they were created. Users were able to create new notifications beyond the limit, but the monitoring service did not alert PhishER that these notifications were not being sent.

Once a new monitoring service was implemented, PhishER was able to return to normal performance by Friday, 11/11/2022, at 11:07 a.m. (ET).

To prevent this type of issue in the future, we customized our new monitoring service to remove the limit for room notifications and implemented better error handling.

No data loss occurred as a result of this issue.

Posted Nov 21, 2022 - 16:22 UTC

Resolved
This incident has been resolved.
Posted Nov 11, 2022 - 18:18 UTC
Monitoring
We have implemented a fix for the issue where some users were not receiving notifications for PhishER rooms. We're monitoring the results to make sure no further issues occur.
Posted Nov 11, 2022 - 17:23 UTC
Identified
We've identified the cause of the issue where some users are not receiving notifications for PhishER Rooms. We are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Nov 08, 2022 - 23:53 UTC
Investigating
We have received reports that some users are not receiving notifications for PhishER Rooms. We are investigating this issue and will update this page when we have more information.
Posted Nov 08, 2022 - 23:51 UTC
This incident affected: PhishER (Notification Service).