KnowBe4 Security Center (KSC) | Human Risk Managment Widget Showing No Results

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 19:12 UTC

Monitoring

We’ve implemented a fix for the Human Risk Management widget and we’re monitoring the results to make sure no further issues occur.
Posted Jun 18, 2026 - 15:43 UTC

Investigating

We have received reports that the Human Risk Managment widget is showing no results in the KnowBe4 Security Center. We are investigating this issue and will update this page when we have more information.
Posted Jun 18, 2026 - 15:13 UTC
This incident affected: KnowBe4 Security Center.