KSAT - Loading Issues

Incident Report for KnowBe4

Postmortem

On Thursday, June 05, 2025, from approximately 3:59 p.m. to 7:56 p.m. (UTC), some customers were unable to access the PasswordIQ or SecurityCoach tabs in the KSAT console.

These issues were caused by a code update to improve developer testing for the console. This update caused unexpected errors for PasswordIQ and SecurityCoach webpages. To resolve this issue, we reverted the update, and PasswordIQ and SecurityCoach features returned to normal performance by 7:56 p.m. (UTC).

To prevent this type of issue in the future, we have revised our deployment workflow for similar updates, and we’ll schedule them to occur during regular maintenance windows.

No data loss occurred as a result of this issue.

Posted Jun 12, 2025 - 18:28 UTC

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 20:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2025 - 17:53 UTC

Investigating

We have received reports that some users are experiencing loading issues with their KSAT consoles when accessing the SecurityCoach and PasswordIQ tabs. We are investigating this issue and will update this page when we have more information.
Posted Jun 05, 2025 - 16:45 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).