KMSAT - Console Issues
Incident Report for KnowBe4
Postmortem

On Monday, 11/1/2021, from approximately 10:23 a.m. until 1:57 p.m. (ET), users experienced delays with login-related emails including email confirmations, passwordless logins, and passwordless reset emails.

These issues were caused by an unexpected increase in email traffic, causing email processing to slow down. Once extra servers were added to process the traffic, login-related emails returned to normal performance by 1:57 p.m. (ET).

To prevent this type of issue in the future, we have implemented a new priority system for login-related emails.

No data loss occurred as a result of this issue.

Posted Nov 05, 2021 - 14:43 UTC

Resolved
This incident has been resolved.
Posted Nov 01, 2021 - 19:06 UTC
Monitoring
We’ve implemented a fix for the login-related email delays and we’re monitoring the results to make sure no further issues occur.
Posted Nov 01, 2021 - 18:08 UTC
Update
We are continuing to work on implementing a fix for the login-related email delays and will update this page when we have more information.
Posted Nov 01, 2021 - 17:17 UTC
Identified
We've identified the cause of the login-related email delays and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Nov 01, 2021 - 15:59 UTC
Investigating
We have received reports that login-related emails are experiencing delays. We are investigating this issue and will update this page when we have more information.
Posted Nov 01, 2021 - 14:27 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).