KMSAT - Download Center Issues
Incident Report for KnowBe4
Postmortem

On Friday, 10/07/2022, from approximately 10:40 a.m. (ET) until Thursday, 10/13/2022, at 12:40 p.m. (ET), some users experienced delayed report downloads.

This incident was caused by a code change that led to high database memory usage. Once this code change was reverted, the Download Center was able to return to normal performance by Thursday, 10/13/2022, at 12:40 p.m. (ET).

To prevent this type of issue in the future, we updated the code to avoid using excessive database memory.

No data loss occurred as a result of this issue.

Posted Oct 20, 2022 - 14:53 UTC

Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 23:57 UTC
Monitoring
We’ve implemented a fix for the download processing issue and we’re monitoring the results to make sure no further issues occur.
Posted Oct 13, 2022 - 21:41 UTC
Investigating
We have received reports that downloads are processing slowly. We are investigating this issue and will update this page when we have more information.
Posted Oct 13, 2022 - 16:16 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Reporting).