KMSAT - Phishing Feature
Incident Report for KnowBe4
Postmortem

On December 3, 2020, from approximately 9:34 a.m. until 1:46 p.m. (ET), some KMSAT phishing functionality was degraded. KMSAT users were unable to select email templates on a phishing campaign, edit or clone existing phishing campaigns, or view the Dashboard page’s phishing report.

These issues occurred after we deployed code that unintentionally affected one of our API calls. This code was corrected around 1:46 p.m. (ET), and full functionality was restored at that time.

To prevent this issue in the future, we have improved the test coverage around the code that failed, so future related issues can be detected prior to deployment.

No data loss occurred as a result of this issue.

Posted Dec 09, 2020 - 20:41 UTC

Resolved
The issues have been resolved. No data loss occurred as a result of these issues.
Posted Dec 03, 2020 - 19:16 UTC
Investigating
We’ve received reports of issues with the Phishing feature of the KMSAT platform, including phishing campaigns and phishing reporting. We are currently working on a fix for this issue and will update this page when we have more information.
Posted Dec 03, 2020 - 18:01 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Phishing, Reporting).