KMSAT - Campaign Creation and Smart Group Update Delays
Incident Report for KnowBe4
Postmortem

On February 3, 2021, at approximately 11:20 a.m. (ET), we deployed a framework update to our KMSAT product that caused delays with the queueing and processing of background jobs. The jobs were still processing but, over the course of a few days, became significantly delayed.

Affected features in KMSAT that experienced delays as a result of this deployment included phishing and training campaigns, the emails associated with these campaigns, and updates to Smart Groups.

We deployed a fix on February 10th, 2021 at 3:00 p.m. (ET) which processed the backlog of jobs and restored the background job processing time to a normal level by 5:00 p.m. (ET). 

No data loss occurred as a result of this issue.

Posted Feb 11, 2021 - 22:32 UTC

Resolved
This issue has been resolved.
Posted Feb 11, 2021 - 14:36 UTC
Update
We are still investigating this issue. Customers might still be experiencing delays with their phishing and training campaigns. We’ve determined that Smart Groups are also affected - updates to Smart Groups may be delayed.
Posted Feb 10, 2021 - 22:07 UTC
Update
We are continuing to investigate this issue.
Posted Feb 10, 2021 - 20:58 UTC
Investigating
We’ve received reports that customers are experiencing delays in KMSAT training and phishing campaign creation. We are looking into this issue and will update this page when we have more information.
Posted Feb 10, 2021 - 20:58 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console, Phishing).