Important Note: We recently updated one of our IPs to optimize email deliverability for our Security Awareness Training (KMSAT) and PhishER platforms.

If you're using Office 365 and you've already whitelisted KnowBe4's IPs but are experiencing email deferments or delays, we recommend setting up a receive connector according to the instructions in this article.

KCM GRC - Metrics Page Issues
Incident Report for KnowBe4
Postmortem

From approximately 5:52 p.m. (ET) to 7:53 p.m. (ET) on 08/04/2020, users were experiencing issues with the KCM console unexpectedly shutting down when trying to access their Detailed Reports page.

These issues were caused by an unusually large number of queries and connection attempts to the database.

To prevent this issue in the future, we will continue monitoring the database for any abnormal querying and will ensure that queries do not request more data than the application is capable of processing. No data loss occurred as a result of this issue.

Posted Aug 11, 2020 - 15:13 EDT

Resolved
This issue has been resolved.
Posted Aug 04, 2020 - 19:53 EDT
Identified
We have identified the cause of this issue and are working on a fix.
Posted Aug 04, 2020 - 18:11 EDT
Investigating
We are currently investigating an issue where the Metrics page is crashing for some users. The Metrics page will be inaccessible as we investigate the cause of this issue.
Posted Aug 04, 2020 - 17:52 EDT
This incident affected: KCM GRC.