Important Note: We recently updated one of our IPs to optimize email deliverability for our Security Awareness Training (KMSAT) and PhishER platforms.

If you're using Office 365 and you've already whitelisted KnowBe4's IPs but are experiencing email deferments or delays, we recommend setting up a receive connector according to the instructions in this article.

Messages may be delayed
Incident Report for KnowBe4
Resolved
This incident has been resolved.
Posted Aug 28, 2019 - 18:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2019 - 18:17 EDT
Identified
We have identified an issue causing sending of emails to be delayed. We have implemented a fix that should improve email delivery and limit additional delay.
Posted Aug 28, 2019 - 17:10 EDT
This incident affected: Kevin Mitnick Security Awareness Training (API).