PhishER Showing Incorrect Subject Line for Inbox Messages

Incident Report for KnowBe4

Postmortem

On Tuesday, March 10, 2026, from approximately 15:22 until 20:35 (UTC), the EU and US instances of the PhishER console displayed an incorrect subject line for some messages reported with the Phish Alert Button (PAB).

This incident was caused by a configuration change to the PhishER message ingester service, which unexpectedly affected messages that were reported with some PAB versions.

Once we reverted the change and updated the ingester service, PhishER was able to return to normal performance by 20:35 (UTC).

To prevent this type of issue in the future, we reviewed the ingester service processes and implemented additional testing for messages reported with the PAB. 

No data loss occurred as a result of this issue.

Posted May 13, 2026 - 17:54 UTC

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 20:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 17:02 UTC

Identified

Our development team has identified an issue causing ingested messages in PhishER to display the incorrect sender address.
Posted Mar 10, 2026 - 15:48 UTC
This incident affected: PhishER (Inbox).